La variable d’environnement PATH

[Vous pouvez passer cette section si vous utilisez un gestionnaire de paquetage tel que MacPorts pour installer LilyPond ; PATH devrait être réglé correctement.]

Dans les différents manuels de LilyPond, les exemples font référence à lilypond comme étant le programme à lancer. Ceci ne fonctionne toutefois que dès lors que la variable d’environnement PATH est réglée de telle sorte qu’elle inclut le répertoire contenant les binaires de LilyPond.

Partant du principe que vous avez déplié le paquetage de la version 2.25.14 de LilyPond dans le répertoire /home/moi, le répertoire des binaires à ajouter à PATH est

/home/moi/lilypond-2.25.14/bin

Sur Windows, il devrait normalement s’agir de

C:\Utilisateurs\moi\lilypond-2.25.14\bin

Consultez la documentation pour votre système opérartoire ou faites une recherche sur internet pour savoir comment modifier PATH. Dans le cas où vous mettez à jour une ancienne version de LilyPond, assurez-vous que l’ancien répertoire de binaires est supprimé de PATH. Vous pourrez alors vérifier qu’un apppel en ligne de commande à lilypond --version renvoie la bonne version.

Si, pour quelque raison que ce soit, vous ne parvenez pas à régler PATH, ou si vous avez plusieurs versions de LilyPond installées, il vous faudra utiliser le chemin complet d’accès au binaire, par exemple

/home/moi/lilypond-2.25.14/bin/lilypond musique.ly

GNU LilyPond – Utilisation des programmes v2.25.14 (branche de développement).