Entwicklung

Entwicklung für LilyPond 2.19.10

Achtung: Hier handelt es sich um nicht stabile Entwicklerversionen. Wenn Sie nicht genau wissen, wie man LilyPond installiert und benutzt, empfehlen wir ausdrücklich, die stabilen Download-Versionen zu benutzen und die stabilen Handbücher zu lesen.

Veröffentlichungsnummern

Es gibt zwei Veröffentlichungsreihen für LilyPond: stabile Versionen und die unstabilen Entwicklerversionen. Stabile Versionen haben eine gerade zweite Versionsnummer (also etwa 2.8, 2.10, 2.12). Entwicklerversionen haben eine ungerade zweite Versionsnummer (also 2.7, 2.9, 2.11).

Download

Anleitungen zu git und der Kompilierung finden sich im Contributor’s Guide (nur auf Englisch).

lilypond git-Repositorium

Schreiber der Dokumentation und Tester sollten die neuesten Binärpakete herunterladen:

GNU/Linux x86: LilyPond 2.19.10-1

GNU/Linux 64: LilyPond 2.19.10-1

GNU/Linux PPC: LilyPond 2.19.10-1

FreeBSD i386: LilyPond 2.19.10-1

FreeBSD amd64: LilyPond 2.19.10-1

MacOS X x86: LilyPond 2.19.10-1

MacOS X PPC: LilyPond 2.19.10-1

Windows: LilyPond 2.19.10-1

Source: lilypond-2.19.10.tar.gz

Handbuch für Entwicklungsarbeiten (Contributor’s guide)

Die Entwicklung von LilyPond ist eine ziemlich komplizierte Angelegenheit. Um neuen Mitarbeitern zu helfen und das ganze System (ziemlich) stabil zu halten, haben wir ein Handbuch für Entwicklungsarbeiten geschrieben (nur auf Englisch).

Regressionsteste

Alle Versionen

Handbücher

Achtung: Diese Handbücher sind für LilyPond 2.19.10; die neuesten Handbücher finden sich auf http://lilypond.org.


Andere Sprachen: English, català, česky, español, français, magyar, italiano, 日本語, nederlands, 中文.
About automatic language selection.

Validation

Thanks to webdev.nl for hosting lilypond.org. Valid HTML 4.01 Transitional